HS720E wi-fi

Nearlypastit

New member
Joined
Nov 26, 2020
Messages
3
Reaction score
2
Age
81
Location
Bexhill on Sea, East Sussex. U.K.
I’m totally new to this. My wife has bought me the Holy Stone HS720E for Christmas, she thinks it will give me something to do in my old age (81). I’ve managed to fly from my back garden fairly successfully, one or two hiccups along the way but when I’ve tried going out and about a bit more, several times I get “unable to connect to Holy Stone wi-fi”. Would this be due to the area I’m in (I live on the south coast of U.K.)? I read somewhere that someone suggested that the phone should be on airplane setting. I have a Samsung S8+.
Any help or suggestions would be gratefully received.
Thanks.
 

Nearlypastit

New member
Joined
Nov 26, 2020
Messages
3
Reaction score
2
Age
81
Location
Bexhill on Sea, East Sussex. U.K.
I’m totally new to this. My wife has bought me the Holy Stone HS720E for Christmas, she thinks it will give me something to do in my old age (81). I’ve managed to fly from my back garden fairly successfully, one or two hiccups along the way but when I’ve tried going out and about a bit more, several times I get “unable to connect to Holy Stone wi-fi”. Would this be due to the area I’m in (I live on the south coast of U.K.)? I read somewhere that someone suggested that the phone should be on airplane setting. I have a Samsung S8+.
Any help or suggestions would be gratefully received.
Thanks.
You can scrap the above, I’m returning the drone and buying a DJI Malik Air 2 Fly More. Hopefully I’ll have more luck with this one.
 
  • Like
Reactions: MNNJR69

pavnish

Member
Joined
Dec 30, 2020
Messages
8
Reaction score
2
Age
56
Location
Raleigh, North Carolina, USA
I’m totally new to this. My wife has bought me the Holy Stone HS720E for Christmas, she thinks it will give me something to do in my old age (81). I’ve managed to fly from my back garden fairly successfully, one or two hiccups along the way but when I’ve tried going out and about a bit more, several times I get “unable to connect to Holy Stone wi-fi”. Would this be due to the area I’m in (I live on the south coast of U.K.)? I read somewhere that someone suggested that the phone should be on airplane setting. I have a Samsung S8+.
Any help or suggestions would be gratefully received.
Thanks.
I just bought it and loving it. Make sure your wifi on your phone is on. Mine connect by it self. Also do calibration before you fly. Hope fully that works out.
 

jdw3rd

Active member
Joined
Jan 9, 2021
Messages
25
Reaction score
8
Age
64
Location
New England USA
If I'm close to a "known" wireless network (one my phone's been told it can auto-connect to) - for example outside in my front yard & close to the house - the stronger signal from my house causes my phone to switch from HolyStone WiFi to my home WiFi.
 

pavnish

Member
Joined
Dec 30, 2020
Messages
8
Reaction score
2
Age
56
Location
Raleigh, North Carolina, USA
I also watched somewhere on YouTube, that it is best if you turn your phone on airplane mode and that what I am doing, So, you don't get distract with other network but HolyStone. And that works for me.
 
  • Like
Reactions: jdw3rd

jdw3rd

Active member
Joined
Jan 9, 2021
Messages
25
Reaction score
8
Age
64
Location
New England USA
On occasion I'll get "unable to connect" to the HolyStone WiFi on my iPhone. When it happens I turn the drone and controller off and POWER DOWN my iPhone. I turn my iPhone back on and then the drone & controller which usually fixes the connect issue
 
  • Like
Reactions: Midnite_tm

Latest threads

Members online

No members online now.

Forum statistics

Threads
423
Messages
1,108
Members
377
Latest member
Tanstaafl