Trouble with XIRO Xplorer V

Bigguy2211

New member
Joined
Nov 19, 2021
Messages
1
Reaction score
0
Age
41
Location
United States
I broke the gimbal arm on my drone a while ago. I repaired it, with an arm and flex cable. I also bought a damaged Xplorer V from eBay that came with a broken gimbal.

I think I remember hooking up the flex cable backwards, the end that connects from the two motors and camera to the gimbal board. And it didn’t turn on. I remember flipping the end of the flex cable plug and hooking it back up and it behaved by the camera pointed down at the table and would jerk from right to left and back to the right and a sit still for about three seconds and repeat this same behavior over and over.

I switched the gimbal boards with the one I bought from eBay. It was a nightmare getting it to pair but I finally got it to work. Shortly after, I was flying to close to my roof inspecting my shingles and I broke the gimbal arm and flex cable again. I got so disgusted that I put it all away and haven’t tried to repair it for over a year.

Just a month ago I decided to order the parts for it from AliExpress. I did not remember when I was repairing it last weekend, to make sure like how the flex cable was plugged into the different circuit boards. I ended up doing what I done when I repaired it the first time.

Powering on the drone gimbal did not respond, took everything apart flip the end of the flex cable around hooked everything back up and now it is behaving like like it did the first time I repaired it. I have tried updating the firmware I have tried pairing the transmitter with the drone. Resetting everything back to factory. I can get the transmitter to pair with my phone on the app then I try to get the repeater/transmitter to pair with the gimbal and it will not come up or be recognized on the app.

It would be much appreciated if someone knew how to possibly get this thing working like it supposed to. Thank you
 

Latest threads

Members online

No members online now.

Forum statistics

Threads
556
Messages
1,596
Members
572
Latest member
Bodmoore