HS 120D, Limited flight distance (more brief ;-D )

mrlewp87

Member
Joined
May 10, 2021
Messages
5
Reaction score
2
Age
70
Location
Florida
I’m testing the limit of the drone’s wifi, and how far I can maintain control of it across our two largest pastures. Nearly 800 ft. or so. On my first attempt, the 120D wouldn’t even go halfway, before hitting a “wall”. Like bouncing off really soft, invisible foam. I was using the phone app.

->> there was no detectable wind
->> it definitely was NOT in Beginners Mode (I turned that Off the very first time using the app)
->> it definitely was Not in “altitude” mode.
->> began with fully charged battery, so it wasn’t trying to return. Unless, the more realistic controller
distance is less than 150 ft.!

Any ideas on the drone’s behavior, refusing to fly more than about 120 ft. out?
 
Last edited:

Bob Johnson

New member
Joined
Jun 13, 2021
Messages
4
Reaction score
1
Age
70
Location
Arizona
The beginner mode turns on every time I turn on the app and I have to turn it off and set the distance each time. I am not sure if this is happening to your drone. But it is worth a look.
 

mrlewp87

Member
Joined
May 10, 2021
Messages
5
Reaction score
2
Age
70
Location
Florida
Thanks. That’s exactly what the problem was. I thought that On/Off applied the parameters set there-On, or removed all flight parameters-Off, ie.; distance. Seemed logical to me. I knew I had turned it Off, so didn’t think it was an issue.
So I turned it ON, which then allows you to change the flight limitations. Set the values higher, then turned it Off again. If it IS- ON at each startup, I haven’t noticed because of the high values I had set.
 
  • Like
Reactions: Bob Johnson

Bob Johnson

New member
Joined
Jun 13, 2021
Messages
4
Reaction score
1
Age
70
Location
Arizona
Thanks. That’s exactly what the problem was. I thought that On/Off applied the parameters set there-On, or removed all flight parameters-Off, ie.; distance. Seemed logical to me. I knew I had turned it Off, so didn’t think it was an issue.
So I turned it ON, which then allows you to change the flight limitations. Set the values higher, then turned it Off again. If it IS- ON at each startup, I haven’t noticed because of the high values I had set.
Glad it helped. We older guys need to stick together and show the youngsters how to do it.
 

Latest threads

Members online

Forum statistics

Threads
501
Messages
1,377
Members
475
Latest member
Wyosmithin