Spektrum DX6 Motor Start

Blademan

New member
Joined
Jul 20, 2023
Messages
1
Reaction score
0
Age
76
Location
Olympic Peninsula Washington
Hi everyone, I'm a defector from the Yuneec Pilot Forum and I'm new here with a Blade/Spektrum question.
I have three Blades, an Inductrix (Mini Hoop), a Blade/Rakon Inductrix-200, and a Blade 200QX. I use a Spektrum DX6 for all three.

These have all been stored for about 5 years while I obsessed over my Yuneec H Plus, but I just dug them out again because I miss the pure fun of flying the small Blades. I bought new batteries for the Inductrix-200 and the 200QX, charged them up, and tried each one separately. Each quickly binds properly, I can change rate modes and each quad responds with the correct LED flashes. but I can't get the motors to start up on either one.

It's been a while so I read the manuals, the 200QX says to move both sticks into the bottom inside corners, then back to center. Doing this does not start the motors. The Inductrix 200 says start the motors by moving the rudder stick to the right. Doing this does not start the motors. I tried both procedures on each one but the motors won't start. The Small Inductrix is the only one that will start up and fly.

I even tried my backup DX6i, again it binds properly, but the motors won't start. It seems like I'm missing something. I'm hoping someone here can shed some light on what I'm doing wrong.

Stress First Aid Kit.jpg
 

Recent Posts

Members online

Forum statistics

Threads
1,111
Messages
3,254
Members
1,353
Latest member
Cardweaver