Potensic D85 Problem

Don Elrod

New member
Joined
Mar 13, 2020
Messages
1
Reaction score
0
Age
58
Location
Ingleside, TX
I have a D85 and when I went to fly it today I attempted calibration. I began with the horizontal calibration and the lights and beeps responded correctly. I attempted the vertical calibration with no success. The lights continued to flash. The drone would not unlock and the motors would not engage. I was in an empty field where I have flown before with no power lines or metal around. I then noticed that the number of satellites connected was 0. I normally have somewhere around 17 satellites. Any ideas what could be causing this?
Thanks.
 

just_hoss

Member
Joined
Aug 29, 2019
Messages
8
Reaction score
2
Age
53
Location
Entiat, WA
Sadly I don't have any technical advice, but try again at home. The bird doesn't need gps to calibrate.

Technical support - "did you take the battery out?" 😉

I would say after a couple of tries with no success, return it. I've had no issues what so ever with mine (just want a better camera).

Best of luck.
 

Michael Starley

New member
Joined
Jan 8, 2020
Messages
3
Reaction score
1
Age
53
Location
Winder, Georgia
Website
www.personaldronerepair.com
I have a D85 and when I went to fly it today I attempted calibration. I began with the horizontal calibration and the lights and beeps responded correctly. I attempted the vertical calibration with no success. The lights continued to flash. The drone would not unlock and the motors would not engage. I was in an empty field where I have flown before with no power lines or metal around. I then noticed that the number of satellites connected was 0. I normally have somewhere around 17 satellites. Any ideas what could be causing this?
Thanks.
Judging from what I have seen here, it sounds like magnetic interference is causing this issue.
Keep in mind that even metal underground can cause this to happen.
Pipes, rebar, etc. .
You get it.
Take the bird to a different location and go through the steps again.
You should be happy with the results.
 

garrisonusa

Member
Joined
May 16, 2020
Messages
5
Reaction score
0
Age
61
Location
Desert Hot Springs CA
The exact same thing I noticed on mine...however I was out in the desert with no obstructions of magfields etc...I had just used the 17 sats etc...but then I noticed my camera app was not actually connected anymore to the drone...so I rebooted that and as soon as it connected it showed the 17sats again...and everything was fine...I think it was the sequence I was turning it off...
 

Latest threads

Members online

No members online now.

Forum statistics

Threads
306
Messages
856
Members
273
Latest member
Ssig