For those with FPV/Phone connection issues with Fimi X8 Pro and X8 SE V2 2022

st468

Member
Joined
Jan 17, 2024
Messages
6
Reaction score
2
Age
49
Location
USA
I want to post this for the benefit of others who experience the problem. I read elsewhere online that there are numerous others who had the same problem as me. This is for those with the newest Samsung Galaxy Android phones-

The issue: No FPV/app connection, the phone app will not connect to the drone. The controller does connect to the drone however, it will operate the gimbal, start the motors, etc. correctly.



Solutions tried: I downloaded the Fimi Navi app to another device, and I plugged the controller into my Apple Ipad which I use for flying real airplanes. It connected right away and worked properly. So I knew at that time it was a phone issue, not a drone issue. The full size Ipad is too large to fly the drone with, I only used it to test.



Focusing back to the phone (Samsung Galaxy S23 unlocked/unbranded running Andriod 14). I tried enabling developer options mode, and I enabled USB debugging. It did not help. Then I went into USB permissions and made sure data was allowed over USB. Still no help. The connection between the phone and controller would charge the phone, so I knew the cable is good. The cable is USB-C at the phone, and full-sized USB at the drone controller. I then tried plugging the phone into my Windows 11 laptop computer with the same cable. Same issue, charges the phone, but no data. Then I tried the Samsung USB-C cable that the phone’s charger uses, USB-C to USB-C, and I plugged that into the computer. Data transfer works just fine then, as it always did. With my Potensic Atom drone, the connection between the controller and phone is USB-C to USB-C, and it always worked perfectly for the data connection with no issues.



Determination: Through extensive online research, and through trial and error, I learned that it is a Samsung issue, not an Android issue. The newest unlocked/unbranded Samsung phones do not allow data through that type of connection, only power is allowed. Connection being- USB-C at the phone, and full size USB at the connected device.



Solution: I tried the included Fimi cord that has Micro USB to full size USB, the same cord used to charge the controller, as well as the cord used for older phones that have only a Micro USB port rather than a USB-C port. I used a USB Micro to USB-C adapter plugged into the phone, then I plugged the above-mentioned Fimi cord into it, and then plugged the full size USB end into the drone controller as required. The connection between the phone app and controller then works perfectly, just like it did when I tested it with the Apple Ipad. The drone flies fine with the APP and every feature works.



Additional notes: With the adapter installed, the phone still fits well in the Fimi controller, it is slightly pushed out from the right side, but it still fits securely and works just fine.

Here is an example of the adapter that makes it work: (Note- I have no affiliation with the Amazon seller of this product)

https://www.amazon.com/Adapter-Alum...1-1-spons&sp_csd=d2lkZ2V0TmFtZT1zcF9hdGY&th=1

I hope this information is helpful for others. Also I have notified Fimi of this, perhaps they will change the controller data port to USB-C in the future...
 
You gave me a ray of hope! I have an iPhone 15 pro and just “play” with drones so I recently got a Potensic Atom SE to keep one upping my last drones. My issue is the exact same as you describe and, again with the newest model out by Apple. I wondered if that may be the case. I told them it was a bad cable (usb-C to USB-C for controller to phone and before they sent another one I ordered a new drone and am returning the other one. When the new one got here..exact same issue. I thought either have the worst luck ever or there’s something going on here with this cable thing. In my world, neither would surprise me but I ordered adapters n a way to see if that’s the issue. I will update upon arrival. Thanks for your post.
 
Apple 15 pro running iOS 17.5 dev beta no problems connecting to my DJI or FIMI drones.
 
Hey, just registered to say that you are a life saver. Thanks a lot for saving me/us a lot of hours to figure this out
 

Recent Posts

Members online

No members online now.

Forum statistics

Threads
1,222
Messages
3,715
Members
1,496
Latest member
I Robot